Jump to content

My character is glitched?

Recommended Posts

Date and time (provide timezone): 2019-02-16  03:29 +1 GMT

Character name: Joe Mohammed

Issue/bug you are reporting: I'm an old player since 2017. When I connected today I was in jail upon release, I tried to rent a car. I could not get the interface to open with Y, Then I ran to Mors Insurance, could not open the interface. Tried to buy a weapon inside the weapon store, could not open the store with the button E. I have no idea why it won't open but in the current state the server is unplayable for me.

Evidence, notes worth mentioning, steps to replicate

Edited by Elias00
Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and our Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.