Jump to content

Eclipse Government log in credentials not working

Recommended Posts

Issue Being Reported: My government log in credentials aren't working

Date and Time of Issue (provide timezone): Friday June 17th 10:38am (GMT+1)

Your characters name: Scarlett Smith

Other player(s) involved: N/A

Evidence and/or notes worth mentioning: I tried logging in with my character name, forum name and my email. None have worked and I am not receiving a password reset link to my email.

Link to comment
Share on other sites

1 hour ago, isBrainDed said:

Government website doesnt use an account linked with Eclipse server.


If you havent made an account on the gov.eclipse-rp.net, you have to create one.

i don’t remember making an account but it says my email is in use when i try to create one 

Link to comment
Share on other sites

3 hours ago, Spizor said:

Try using the "forgot password" option and input your email. The email sent to you will include the username at the top and a link to reset your password.

i have done this and i don’t receive an email, i’ve checked in my junk and it’s not there either 

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and our Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.